프로그래밍2012.02.28 17:58
ubuntu 10.04 기준으로 작성

apache2 소스를 받아 configure를 해보면 apr, aprutil, pcre가 각각 필요한데
apr과 aprutil을 apt-get을 이용해 설치를 하게되면 최신버전이 아니어서 그런지 configure는 성공하지만 make할때 에러가 발생하는 경우가 생긴다. (난 apr_file_link 에러가 발생했다)

수동으로 빌드하기로 마음먹었으면 라이브러리도 수동으로 설치하자.

apr & aprutil
http://apr.apache.org/download.cgi 

pcre
http://pcre.org/ 

apr은 간단함
$ ./configure --prefix=/usr/local/apr
$ make
$ sudo make install 

aprutil은 apr경로 지정해줘야함
$ ./configure --prefix=/usr/local/aprutil --with-apr=/usr/local/apr
$ make
$ sudo make install 

pcre도 간단함
$ ./configure --prefix=/usr/local/apr
$ make
$ sudo make install 


이제 아파치 소스 디렉토리로 가서 아래처럼 경로를 지정해주자
$ ./configure --prefix=/usr/local/apache2 --with-apr=/usr/local/apr --with-apr-util=/usr/local/aprutil --with-pcre=/usr/local/pcre --enable-module=so --enable-so
$ make
$ sudo make install


빌드가 완료되었으면 테스트
$  /usr/local/apache2/bin/apachectl -k start
netstat -ntl 해봤을때 80번 포트 열리면 성공 

자동으로 시스템 부팅시 실행되도록 서비스 등록
실행 스크립트를 init.d에 복사한 뒤 update-rc.d 이용
$ sudo cp /usr/local/apache2/bin/apachectl /etc/init.d/apache
$ sudo update-rc.d  apache defaults
저작자 표시 비영리 변경 금지
신고


License
달리 정하지 않는 한, 이 저작물 크리에이티브 커먼즈 코리아 저작자표시-비영리-변경금지 2.0 대한민국 라이센스에 따라 이용하실 수 있습니다.
Except where otherwise noted, this content is licensed under a Creative Commons Attribution-NonCommercial-NoDerivs 2.0 Korea License
Posted by Widyou

댓글을 달아 주세요