colinux + fedora 10 환경에 루비 1.9.1 수동으로 다운받아 컴파일해서 설치한 경우 gem 실행시 zlib 가 로드되지 않는 문제가 발생했다.
이짓저짓을 해도 안됬는데 zlib 패키지는 깔려있어도 zlib-devel 패키지가 있어야 해결된다.
레일스를 위해선 openssl-devel 패키지도 미리 깔아야 한다.

# yum install zlib-devel openssl-devel
명령으로 zlib,openssl 개발 패키지를 설치 한 다음에 루비를 다시 설치하니 잘 된다.

이제 레일즈나 다시 만져봐야지




License
달리 정하지 않는 한, 이 저작물 크리에이티브 커먼즈 코리아 저작자표시-비영리-변경금지 2.0 대한민국 라이센스에 따라 이용하실 수 있습니다.
Except where otherwise noted, this content is licensed under a Creative Commons Attribution-NonCommercial-NoDerivs 2.0 Korea License
  1. yedge 2009.04.22 04:37 신고

    페도라 쓰나 보네 이제


    레일즈는 모냐

+ Recent posts